Funciones SUMA y SUMAR.SI

Seguimos con las funciones que utilizaré en "Cómo hacer una planilla de cálculo para administrar el PRODE entre amig@s o compañer@s". Las 2 funciones restantes, son SUMA y SUMAR.SI



FUNCIÓN SUMA

La más sencilla de las 2, que no reviste mucho análisis. Se utiliza poniendo siempre el signo = delante de la fórmula, la función SUMA y, entre paréntesis, QUE se va a sumar (pueden ser números, celdas o rangos de celdas).

Ejemplos:

=SUMA(1;2;4) Lo que hace, es 1+2+4. En este caso, el resultado sería 7.



=SUMA(A1;A2) Suma los contenidos de las celdas A1 y A2 (si en A1 hay un 5 y en la A2 hay un 3, el resultado será 8)

=SUMA(A1:A5) Suma los números contenidos en el rango de celdas que va de A1 a A5 (A1+A2+A3+A4+A5)



FUNCIÓN SUMAR.SISupongamos que durante un mes, los días de semana salgo a caminar. Y anoto cada día, la cantidad de cuadras que caminé. A fin de mes, quiero saber cuántas cuadras caminé los lunes, cuántas los martes, cuántas los miércoles, etc. Pondríamos en un cuadernito, en el primer renglón "Lunes caminé 3 cuadras", "Martes caminé 6 cuadras", etc...
¿Como resolveríamos, mecánicamente, este problema? Agarraríamos una calculadora, buscaríamos los renglones que dicen "lunes", sumaríamos las cuadras caminadas y tendríamos las cuadras caminadas los días lunes. Haríamos lo propio con los martes, los miércoles, los jueves y los viernes.

La mecánica de excel es igual: busca en un determinado rango la condición (en este caso, que diga "lunes", que diga "martes", etc) y, si cumple con la misma, suma el número del rango de suma de la fórmula.

=SUMAR.SI(rango a analizar;criterio/condición;rango de suma)


Hacer click sobre la imágen para ampliarla

En la imágen, vemos las 4 semanas y el resumen abajo. Es decir, en la celda "C25" ponemos la fórmula:
=SUMAR.SI(B4:B23;"Lunes";C4:C23)
Excel va a buscar en el rango B4:B23 todos los que cumplan el criterio "Lunes" y los va a sumar.

Luego,
En C26, ponemos =SUMAR.SI(B4:B23;"Martes";C4:C23)
En C27, ponemos =SUMAR.SI(B4:B23;"Miércoles";C4:C23)
En C28, ponemos =SUMAR.SI(B4:B23;"Jueves";C4:C23)
En C29, ponemos =SUMAR.SI(B4:B23;"Viernes";C4:C23)

Cualquier duda, la dejan en comentarios!


Hacé clic para ver de que forma podés colaborar con nosotros:

Como colaborar

Hasta la próxima!


7 comentarios:

  1. Hola, y si en las celdas B4:b13 se pone la fecha, y abajo lo dejas igual, como harias para que que te sume los dias Lunes?

    ResponderEliminar
    Respuestas
    1. Hola! Esta entrada es para "SUMAR.SI". Lo que planteás, ya involucra funciones de fecha. Pero te contesto:
      Agregaría en la columna "A" la fórmula:
      =DIASEM(B4)
      Esto te va a tirar un número del 1 al 7, donde 1 es domingo, 2 es lunes, 3 martes, 4 miércoles, 5 jueves, 6 viernes y 7 sábado..
      Ahora, sabiendo eso:
      Si querés sumar los lunes con fecha, en C26:
      =SUMAR.SI(A4:A23;2;C4:C23)

      Otra forma: ponés la columna A, hacés lo que te dije "DIASEM", y en C ponés:

      =ELEGIR(A4;"Domingo";"Lunes";"Martes";"Miércoles";"Jueves";"Viernes";"Sábado")

      Lo que hace "Elegir" es tomar lo que dice A4 y elegir el índice: si es 0 pone domingo, si es 1 pone lunes, etc. El resto lo dejás igual al ejemplo y debería andar.

      Saludos y gracias por comentar.

      Eliminar
    2. Rectifico una cosa: en elegir, el primer índice es 1, no 0. Entonces, si A4 es 1 pone domingo, si es 2 pone lunes, etc.

      Eliminar
  2. hola! solo sirve para un rango ? ponele como hiciste vos c4:c26
    si quiero tambien que busque en otra hoja por ejemplo, o en otra columna (d4:d26) podria agregarlo a la formula ?

    ResponderEliminar
    Respuestas
    1. Hola! Por supuesto, el rango lo aplicás vos. Saludos!

      Eliminar
  3. Hola. En mi caso estoy elaborando una planilla anual de compras y ventas par cada cliente para control del Saldo Técnico y Saldo de Libre Disponibilidad en IVA manteniéndolas por separado en columnas diferentes. Por lo tanto, necesito crear una formula SI para que me sume el saldo técnico o de libre disponibilidad del periodo anterior si es positivo (>0) y que no me sume los saldos si es negativo (<0); a su vez, para obtener el Saldo de Libre Disponibilidad debe absorber el Saldo Técnico negativo (si lo hubiere)... Hasta el momento no he dado con la fórmula. Si me pueden ayudar, será de mucha utilidad. Saludos.

    ResponderEliminar
  4. Hola, tengo un libro que quiero compartir y recibir un poco de ayuda para mejorarlo. Es util para torneos de arqueria, base de datos, puntaje y resutlados. Decime como puedo enviartelo.
    gracias.
    Martin

    ResponderEliminar

Te puede interesar: