Función SI

Hola amigos. Bueno, antes de publicar mi próxima entrada, que será "Cómo hacer una planilla de cálculo para administrar el PRODE entre amig@s o compañer@s", vamos a ver tres fórmulas que utilizaremos en la misma. Comenzamos por la función SI.

Debo decir que la fórmula "si" o condicional , la utilizamos en gran parte de nuestro razonamiento diario. Esto es algo cierto. Veamos un ejemplo:

Siempre que llueve, uso paraguas.

¿Que pregunta inconsciente nos hacemos? Piensen, para eso Dios les regaló eso que tiene pelos y soporta los hombros...

... obviamente nos preguntamos si llueve o no!



Entonces, esto quedaría planteado así:

Si LLUEVE, llevo paraguas. Sino, no.

La fórmula con "léxico" de excel:

=SI(condición ; Que hacer si la condición es verdadera ; Que hacer si la condición es falsa)

Excel utiliza el punto y coma (;) para separar las sentencias y el signo IGUAL para decirle que vamos a poner una función. Entonces, nuestro ejemplo (si excel utilizara nuestro lenguaje), sería:

=SI(llueve ; llevo paraguas ; no llevo paraguas)

Un ejemplo en Excel: vamos a hacer que nos diga si un número es positivo o negativo.
Abrimos Excel (utilizo el 2003), y en la celda "C2" ponemos:

=SI(B2<0;"Negativo";"Positivo")


Hacer click sobre la imágen para ampliarla

NOTA: Siempre que utilicemos una palabra (mejor llamada "cadena de texto" o "string"), la misma se pone entre comillas ("Negativo", "Positivo").

Lo que va a hacer Excel (y lo va a hacer cada vez que B2 cambie de valor) es consultar si B2 es menor a 0. Si esto es cierto (verdadero), en C2 va a poner la palabra "Negativo". Si esto es falso, va a poner la palabra "positivo".

Ahora, a probar: si en la celda B2 ponemos el número 3, la celda C2 dirá "Positivo". Si ponemos -10, dirá "negativo".

Función SI anidada

Supongamos que en los días de lluvia, si llueve fuerte llevamos el paraguas. Si no llueve fuerte, llevamos piloto. Ya tenemos otra condición, dentro de la condición de "llueve".

La fórmula con "léxico" de excel:

=SI(llueve ; SI ( llueve fuerte ; llevamos paraguas ; llevamos piloto) ; no llevo nada)

Esto es una función SI anidada. Si se da la primera condición (llueve), en la parte de la condición verdadera tenemos otra pregunta: Llueve fuerte o no? Entramos en otra fórmula SI para saber si llevamos paragua!

En nuestro ejemplo, ahora, vamos a evaluar si el número es positivo, si es negativo o si es CERO!

=SI(B2<0;"Negativo"; SI(B2=0;"CERO";"Positivo"))

Acá pusimos el segundo "SI" en la condición negativa de la primera función:

=SI (B2> 0;
Si la respuesta es positiva: "Negativo";
Si la respuesta es negativa, entramos en el siguiente SI:
(SI B2=0;
Si la respuesta es positiva: "CERO";
Si la respuesta es negativa: "Positivo"
)
)


Hacer click sobre la imágen para ampliarla

10 comentarios:

  1. jajajaja wenisima
    =SI(llueve ; SI ( llueve fuerte ; llevamos paraguas ; llevamos piloto) ; no llevo nada)

    ResponderEliminar
    Respuestas
    1. Muy buena explicación, esto era precisamente lo que estaba buscando.

      Eliminar
  2. Gracias a todos por los comentarios! Saludos

    ResponderEliminar
  3. Ufff yo estoy peleada con Excel. Estoy haciendo un balance de gastos y quiero que cada vez que el total sea positivo aparezca como tal en la celda y cuando no que ponga negativo, no se como hacerlo.

    ResponderEliminar
  4. En excel tengo un formato de recibo de sueldos, con dos pestañas.
    uno del formato y el otro con la formula del calculo de subsidio y retención
    como hacer que cuando sea subsidio me aparezca en la celda de subsidio y cuando sea retención este en la celda de retención

    ResponderEliminar
  5. excelente, muchas gracias por tu ejemplo... saludos desde ciudad valles, san luis potosi, Mexico.

    ResponderEliminar
    Respuestas
    1. Muchas gracias Marcos, nos alegra que te sirva. Saludos!

      Eliminar

Te puede interesar: